Написать программу в лазарусе. дана строка. написать программу,которая находит и заменяет во всей строке цифры от 0 до 9 на слова "ноль", "один" "девять". преобразованную строку вывести на екран.

Iasia198 Iasia198    1   02.09.2019 06:30    3

Ответы
liudmilka19091982 liudmilka19091982  06.10.2020 11:15
Var
   S:string;
   i:integer;
begin
  ReadLn(S);
  i:=1;
  While i<=Length(S) do
     Begin
     if ('0'<=S[i])and(S[i]<='9') then
        Case S[i] of
        '0':
           Begin
             Delete(S,i,1);
             Insert('ноль',S,i);
           end;
        '1':
           Begin
             Delete(S,i,1);
             Insert('один',S,i);
             i:=i+3
           end;
        '2':
           Begin
             Delete(S,i,1);
             Insert('два',S,i);
             i:=i+2
           end;
        '3':
           Begin
             Delete(S,i,1);
             Insert('три',S,i);
             i:=i+2
           end;
        '4':
           Begin
             Delete(S,i,1);
             Insert('четыре',S,i);
             i:=i+5
           end;
        '5':
           Begin
             Delete(S,i,1);
             Insert('пять',S,i);
             i:=i+3
           end;
        '6':
           Begin
             Delete(S,i,1);
             Insert('шесть',S,i);
             i:=i+4
           end;
        '7':
           Begin
             Delete(S,i,1);
             Insert('семь',S,i);
             i:=i+3
           end;
        '8':
           Begin
             Delete(S,i,1);
             Insert('восемь',S,i);
             i:=i+5
           end;
        '9':
           Begin
             Delete(S,i,1);
             Insert('девять',S,i);
             i:=i+5
           end;
        end;
        i:=i+1
        End;
  WriteLn(S);
  ReadLn;
end.

Для того, чтобы данная программа заработала, нажмите: Файл → создать → простейшая программа.

Если русские буквы отображаются правильно, нажмите правой кнопкой мыши по коду, выберите: параметры файла → кодировка → Ansi (cp1251).
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика