Написать программу в C++. Дано натуральное число n (n<1000) Определить: а) сколько цифр в числе б) чему равна сумма его цифр очень нужно!!

damirpro damirpro    3   24.05.2021 07:56    3

Ответы
Brainly223331156 Brainly223331156  23.06.2021 07:58

#include <iostream>

using namespace std;

signed main(){

   int n, cnt = 0, sum = 0;

   cin >> n;

   while(n > 0){

       cnt++;

       sum += n % 10;

       n /= 10;

   }

   cout << "amount of digits : " << cnt << "\n";

   cout << "sum of digits : " << sum;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика