tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу умножения
Написать программу умножения двух чисел по методу аль-хорезми с++ 11 13 5 26 2 52 (вычёркиваем) 1 104 143 (ответ)
vikavikt
2 31.08.2019 12:10
8
Ответы
NarutoUzumaki1999
26.04.2020 14:30
#include<iostream>
using namespace std;
int main()
{
int A,B,C = 0;
cin >> A >> B;
while(A > 1)
{
if (A % 2 != 0) C+=B;
B*=2;
A/=2;
}
cout << (C+=B);
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dias200620
08.06.2019 05:40
Нужна ,в программе кумир ,надо решить ,и прислать ответы: 1)найти сумму чисел от 1 до 10 2)найти сумму чётных чисел от 2 до 30 3)найти сумму нечётных чисел от 1 до 30...
253n
08.06.2019 05:40
Дан массив из n целых чисел. найти номер первого элемента, который равен количеству элементов, кратных 3. составить программу алгоритма поиска в паскале...
aish17
17.04.2020 14:59
Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [100,500] и выводит его на экран. После этого на экран выводятся суммы цифр всех...
daniil326
17.04.2020 14:59
Составить программы в PascalABC: 1. Составить программу нахождения произведения цифр вводимого с клавиатуры четырёхзначного числа. (Например, число 2351, результат 30)....
АминаМингазова
29.09.2019 08:20
Дано действительное a.не пользуясь никакими другими операциями кроме умножения, получить a3 и a10 за четыре операции. написать на языке pascal...
VLev147741
04.05.2021 11:26
А) АВ – диаметр окружности с центром О. Найдите координаты центра окружности, если А (8;-3) и В (-2;5). b) Запишите уравнение окружности, используя условия пункта а)...
маша9393
04.05.2021 11:26
Тапсырма. Мәтіндерді түсініп оқып, 2 мәтіннің стилін, тақырыбын, мазмұнын салыстырып жаз. 1-мәтінҰлы ақын, ағартушы, қазақтың жазба және әдеби тілінің негізін салушы...
Daleton
04.05.2021 11:26
Мәтіндегі негізгі ақпараттарды іріктеп, қосымша ақпараттарды анықтап, тірек сөздерді, сөз тіркестерін анықтаңыз ...
aizhan05
04.05.2021 11:26
Бала тәрбиесінде кімнің рөлі маңызды. Әженің бе ананың ба...
КаМиЛлА2911
04.05.2021 11:26
Китай для защиты своих границ от кочевников построил...
Популярные вопросы
Впрямоугольном треугольнике с катетами а и b найти биссектрису прямого...
3
Делится на цело на 18 числа: 189, 252, 456, 1998, 1999?...
2
Найдите значения синуса, косинуса, тангенса и котангнса угла альфа...
2
Подчеркните орфограммы в словах легко, найти, по компасу, тёмный,...
2
14/11 х 0,22 (одна целая четыре одиннадцатых умножить на ноль целых...
3
Назовите вещества, из которых состоят следующие тела: велосипедная...
1
Разобрать по членам предложения и расставить запятые 1)об этом писано...
3
1,1(5x-4), 0.2(10x-43). решите . нужно!...
2
Напишите уравнение реакций с которых можно осуществить следующие превращения...
2
Равенства на сложение используя числа 2,5 и 7...
3
using namespace std;
int main()
{
int A,B,C = 0;
cin >> A >> B;
while(A > 1)
{
if (A % 2 != 0) C+=B;
B*=2;
A/=2;
}
cout << (C+=B);
return 0;
}