Написать программу с++ заполнить массив двенадцатью первыми членами последовательности в которой первые два члена равны 1, а каждый следующий равен сумме двух предыдущих и вывести на экран через запятую

marius95 marius95    1   10.09.2019 01:40    1

Ответы
amid69 amid69  16.08.2020 13:01
#include <iostream>
using namespace std;

int main() {
int n=12;
int a[n];
a[0]=1;
a[1]=1;
for (int i=2; i<n; i++){
 a[i] = a[i-2]+a[i-1];
}
for (int i=0; i<n-1; i++){
 cout << a[i] << ",";
}
cout << a[n-1] << "\n";
return 0;
}

Результат:
1,1,2,3,5,8,13,21,34,55,89,144
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика