Написать программу с функцией,которая возвращает в основную программу кол-во гласных букв

oligayaraya oligayaraya    2   19.05.2019 11:12    0

Ответы
saule844007 saule844007  30.09.2020 22:44

program raf105;

var  

 s: string;

 g: integer;

 

function glas(s:string): integer;

const

 glas_list = 'аяоёуюыиэе';

var  

 i,j,res:integer;

begin

 s:= lowercase(s);

 for i:=1 to length(s) do

   for j:=1 to length(glas_list) do

     if s[i] = glas_list[j]

       then res:= res + 1;

glas:= res;

end;

begin

write('Введите строку: ');

readln(s);

g:= glas(s);

writeln('В строке ',g,' глас.');

end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика