Написать программу с++ "дано трех значное число, необходимо найти старшую цифру и вывести на экран надпись , какая из цифр наибольшая "

dianadavletova dianadavletova    1   24.06.2019 11:00    2

Ответы
OToMCTuTEL OToMCTuTEL  19.07.2020 23:13
#include <iostream>
using namespace std;
int main()
{
 int n,m,p;
 cin>>n;
 int n1=n/100;
 int n2=(n/10)%10;
 int n3=n%10;
 if (n1>n2)
    if (n1>n3) {m=n1; p=1;} else {m=n3; p=3;}
 else
    if (n2>n3) {m=n2; p=2;} else {m=n3; p=3;}
 cout<<"max="<<m<<", poz= "<<p<<endl;
 system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика