Написать программу. программа должна осуществлять ввод и печать исходного одномерного массива; выполнять в соответствии с условиями действия и печатать результаты. вычислить сумму ненулевых чисел, стоящих на четных местах, и подсчитать количество чисел, принадлежащих промежутку [m, k].

afanasevaboom123 afanasevaboom123    1   19.03.2019 03:50    21

Ответы
mazyrin91p08sby mazyrin91p08sby  26.05.2020 02:24

var a:array[1..10,1..10]of integer;
i,j,m,k,s:integer;
begin
for i:=1 to 10 do for j:=1 to 10 do readln(a[i,j]);
for i:=1 to 10 do begin for j:=1 to 10 do write(a[i,j],' '); if j=10 then writeln; end;

for i:=1 to 10 do
for j:=1 to 10 do
if (a[i,j]<>0) and (i mod 2=0) then s:=s+a[i,j];
writeln(s);
readln(m,k);
s:=0;
for i:=1 to 10 do
for j:=1 to 10 do
if (a[i,j]>=m) and (a[i,j]<=k) then s:=s+1;
writeln(s);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика