tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу при
Написать программу при регулярныхвыражений, которая проверяет, является ли введенная с клавиатуры строка целым числом.
valikkk1
2 31.08.2019 06:10
14
Ответы
567н
06.10.2020 06:33
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
var s1:=s.MatchValue('[\+-]?\d+');
if s1=s then Writeln('Целое число')
else Writeln('Не целое число')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
МахмудШар
09.07.2019 11:10
Дано три числа, записанный в отдельных строках. упорядочите их в порядке неубывания. программа должна считывать три числа a, b, c, затем программа должна менять их значения так,...
lenab85
09.07.2019 11:10
Если информацию можно использовать то она...
tolkov05
09.07.2019 11:10
Пусть а= ане нравятся уроки , а b= ане нравятся уроки выразите следующие формулы на обычном языке. 1) (a & b): 2) (a v b): 3) (a & -b)...
ЮлияБогинская
24.10.2019 18:33
Типи даних lazarus на украинском...
клинт
24.10.2019 18:34
Решите с номера 2 по 5.в 5ом номере написано : чему равно значение переменной b ...
умница20063
05.10.2019 11:30
Запишите алгоритм преготовления яичницы из трех яиц...
SeetFatRed819
05.10.2019 11:30
Составить описание класса многочленов от одной переменной, задаваемых степенью многочлена и массивом коэффициентов. предусмотреть методы для вычисления значения многочлена для заданного...
ггвв
05.10.2019 11:40
Какое значение получит переменная y после выполнения алгоритма? x: =4y: =5∗xy: =y+2y: =y∗xy: =y+3y: =y∗xy: =y+4...
yulyakarpenko3
05.10.2019 11:40
Какие основные типы переменных используются в языке программирования visual basic? gambas? openoffice.org basic?...
zizizineb99
05.10.2019 11:40
Язык c++ дано два натуральных числа a, b; a∈n; b∈n. на отрезке от a до b требуется найти натуральное число с максимальным произведением его цифр. каким образом это можно сделать...
Популярные вопросы
В чем разница reach и achieve? Приведите несколько примеров с переводом к каждому...
3
Найдите значение выражения 6а+5в/в,если а-в/а=4....
2
Какова идейная подоплека восстания декабристов? Сделайте вывод по проблеме: нужны...
1
Тренадцатый если не сложно....
1
Кто шарит в электронике и пайке подскажите . Разобрал старую мембранку и заметил...
1
диаметр круга равен 32.6 значение числа пи 3.14 определи площадь этого круга...
3
1. Определите по географическому атласу для 8 класса города, где расположены...
3
Познакомьтесь с ситуацией и ответьте на вопрос. Неля приобрела в магазине заколку...
2
4. Возьми интервью у одноклассников. ☆...
3
Команда из трёх мотоциклистов участвовала в гонке. Каждый из них проехал трассу...
3
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
var s1:=s.MatchValue('[\+-]?\d+');
if s1=s then Writeln('Целое число')
else Writeln('Не целое число')
end.