tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу поиска
Написать программу поиска значения максимального элемента массива
Сашок311
3 24.05.2019 15:40
0
Ответы
Abdulla2009
20.06.2020 12:53
Const n=10;
Var a:array[1..n] of integer; i,max:integer;
Begin
randomize;
for i:=1 to n do a[i]:=random(201)-100;
for i:=1 to n do write(a[i],' ');
writeln;
max:=a[1];
for i:=2 to n do
if a[i]>max then max:=a[i];
writeln('max=',max);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Grelil55
31.03.2020 17:07
Что в этом случае обозначают стрелочки вниз? ...
Usdied
31.03.2020 17:08
решить задачу на Python, Составить программу,которая в данной массиве из 40 случайных элементов от -5 до 5, которая определяет количество отрицательных элементов и находит сумму чисел,...
Lulera
31.03.2020 17:19
Какую формулу нужно записать в ячейку A5, чтобы вычислить сумму чисел, содержащихся в диапазоне ячеек A1 : A4?А) =СУММ(A1 ; A4);Б) =СУММ(A1 : A4);В) A5 = СУММ(A1 : A4);Г) A1 + A2...
ilyapleshakov29
20.10.2020 07:35
составтьте предложения , используя слова :авторское право,цивровая репутация,собственность автомотические подключение. ...
047897
20.10.2020 07:08
Каковы функции операционной системы?Опишите процесс установки и загрузки операционной системы используя рисунок 1.32.Каким образом можно загрузить операционную систему (перезагрузить...
rejngardtdiana
20.10.2020 07:38
Какие возможны риски в сети Интернет при использовании ненадежных паролей? 1 легко взломать и получить доступ к личной информации 2легко взломать и прочитать личные сообщения 3легко...
Makarzzz
20.10.2020 07:13
кто разбирается в сделать задание ( )...
Валерия1804
20.10.2020 07:11
1)Запишите константу в форме с фиксированной запятой: A= 0,5E-4 2)Запишиеь числовую константу А в форме с плавующей запятой: А=16000 ПОЖАЙЛУСТА!...
alya5511Аля
20.10.2020 07:11
Сложить в двоичной системе:1) 525+3252) 660+2913) 299+301...
MaМальчик
20.10.2020 07:11
Космический аппарат делает фотографии высокого разрешения с палитрой, содержащей 2³⁰ = 1 073 741 824 цветов. Средний размер фотографии составляет 198 Мбайт. Для хранения в базе данных...
Популярные вопросы
Кпд теплового двигателя 30% рабочое тело получило от нагревателя 5 кдж теплоты.рассичайте...
2
Мяч бросают вниз с высоты h₁=1,8 м со скоростью υ₁= 8 м/с. на какую высоту h₂ отскочит...
2
Как празднуют новый год на кубани ? умоляю...
1
Что обозначает слово утешение? . заранее...
2
Какими общими свойствами мел и поваренная соль....
2
Напишите статью на тему гоголь и петербург...
1
Составьте уравнения электролитической диссоциации растворов следующих веществ:...
2
Найди значение выражения. (1∨1)∨(1∨1)∨(1∨1)...
3
Нужно решить, желательно с объяснением определить объем одного моль газа при давлении...
2
578 700 000 000 м3 перевести в трлн м3 87 млн т перевести в млрд т...
1
Var a:array[1..n] of integer; i,max:integer;
Begin
randomize;
for i:=1 to n do a[i]:=random(201)-100;
for i:=1 to n do write(a[i],' ');
writeln;
max:=a[1];
for i:=2 to n do
if a[i]>max then max:=a[i];
writeln('max=',max);
End.