Написать программу поиска минимального значения в массиве, вывести на экран минимальное значение и номер (индекс) этого значения.

Даша5391 Даша5391    1   08.09.2019 23:50    1

Ответы
lesya16146 lesya16146  20.08.2020 23:43
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var i:=a.IndexMin;
  Writeln('Минимальный элемент ',a[i],' имеет индекс ',i+1)
end.

Пример
n= 15
66 -91 75 27 7 -95 96 48 -35 77 49 71 -13 25 -8
Минимальный элемент -95 имеет индекс 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика