Написать программу по : автомат получает на вход четырехзначное десятичное число. по полученному числу строится новое десятичное число по следующим правилам. 1. вычисляются два числа -сумма двух старших и сумма двух младших разрядов. 2. полученные два числа записываются друг за другом в порядке невозрастания (без разделителей).

vlipinskiy16 vlipinskiy16    3   24.08.2019 10:30    0

Ответы
Виолетта2209 Виолетта2209  05.10.2020 16:25
Var
A,B:integer;
Begin
ReadLn(A);
B:=(A div 1000) + ((A div 100) mod 10);
A:=((A div 10) mod 10)+ (A mod 10);
if A>=B then Write(B,A)
else if B>=A then Write(B,A)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика