Написать программу паскаль вообще не шарю в программах,а так 2 ! «a»: ввести натуральное число и найти сумму его цифр. пример: введите натуральное число: 12345. сумма цифр 15. «b»: ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. пример: введите натуральное число: 12342 нет. пример: введите натуральное число: 12245 да.

папа11111111111111 папа11111111111111    3   28.09.2019 19:20    5

Ответы
Trolololo09 Trolololo09  09.10.2020 01:12

A)

var num, sum, i, temp: Integer;


begin


print('Number: ');


readln(num);


temp:= num;


i:=1;


while(temp <> 0) do


 begin


 temp:= temp div 10;


 if(temp =0) then break;


 i:= i+1;


 end;


temp:= i;


sum:=0;


for i:=0 to temp do


 begin


 sum:= sum + (num mod 10);


 num:= num div 10;


 end;


println('Sum: ',sum);


end.


B)


var num, temp: Integer;

   bool:boolean;    

begin

readln(num);

temp := num mod 10;

num := num div 10;

while(num<>0) do

 begin

 if (temp = num mod 10)  

   then

   begin

   bool:=true;

   break;

   end;

 temp := num mod 10;

 num := num div 10;

 end;

if bool then write('Yes') else write('No');

end.

ПОКАЗАТЬ ОТВЕТЫ
Beliya1 Beliya1  09.10.2020 01:12

begin

 var s := ReadString('n =');

 s.Aggregate(0, (Sum, x)-> Sum + x.toDigit).Println;

 

 var i := 2;

 while (i <= s.Length) and (s[i] <> s[i - 1]) do i += 1;

 

 Print(i > s.Length ? 'No' : 'Yes')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика