Написать программу(паскаль). с пояснениями, желательно. нужно с for. найти сумму всех n-значных чисел, кратных k.(1 < (или равно) n< (или равно)4).

alexandrcrivuli alexandrcrivuli    1   18.05.2019 21:20    5

Ответы
Sofiko20017 Sofiko20017  30.09.2020 21:15

program sada;

var k,n,res,i:integer;

     temp:string;

begin

res:=0;

readln(k);

temp:='';

for i:=1 to n do

temp:=temp+'9';

n:=strtoint(temp);

for i:=1 to n do begin

if (i mod k = 0) then res:=res+i;

end;

writeln(res);

end.

 

 

p.s. Программа написана на pascalABC

ПОКАЗАТЬ ОТВЕТЫ
SoniaGradient SoniaGradient  30.09.2020 21:15

var

  k, n, Summ, i, max, min:integer;

begin

  write('n = '); readln(n);

  write('k = '); readln(k);

  max := 9;

  min := 1;

  for i := 2 to n do

  begin

    max := max * 10 + 9;

    min := min * 10;

  end;

  for i := min to max do

    if i mod k = 0 then

      Summ := Summ + i;

  writeln('Сумма = ', Summ);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика