Написать программу Паскаль! 1.Вывести на экран и подсчитать количество натуральных чисел типа longint,
которые при делении на заданное простое число х, дают в остатке число у.
2.Найти простые числа х и у, которые в произведении дают число z, типа
longint.

timurtim1 timurtim1    2   12.12.2021 18:39    1

Ответы
sambovladikvladik sambovladikvladik  01.02.2022 03:28

Программа:

Pascal:

var

 y: real;

 n, j: longint;

 i, x: integer;

begin

 write('x = ');  readln(x);

 write('y = ');  readln(y);

 j := MAXINT;

 for i := 1 to j do

   if i mod x = y then inc(n);

 writeln(n, ' чисел');

 

end.

Результат:

x =  5

y =  3

429496729 чисел

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика