Написать программу осуществляющую поиск в одномерном массиве a, состоящего из 20 элементов, заданных случайным образом элемента, равного 50. если такого нет, вывести на экран сообщение “такого нет”.

Варежкамяу Варежкамяу    3   04.10.2019 10:50    3

Ответы
Умник333331 Умник333331  09.10.2020 19:25

var a:array[1..20] of integer;

i,k: integer;

begin

for i:=1 to 20 do

begin

a[i]:=random(51)+25;

write (a[i],' ')

end;

writeln;

for i:=1 to 20 do

if a[i]=50 then

begin

writeln (i,' элемент = ',a[i]);

k:=k+1

end;

if k=0 then writeln ('Такого нет')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика