Написать программу, одномерный массив из 15 элементов. значения членов массива вводятся при выполнении программы. программа должна находить минимальный и максимальный члены массива и их номера.
Var mas: array[1..15] of integer; i, min, max, nMin, nMax:integer; begin writeln('Введите 15 элементов массива'); for i := 1 to 15 do readln(mas[i]); min := mas[1]; max := mas[1]; nMin := 1; nMax := 1; for i := 1 to 15 do begin if max < mas[i] then begin max := mas[i]; nMax := i; end; if min > mas[i] then begin min := mas[i]; nMin := i; end; end; writeln('Максимальное число и его номер ', max, ' ', nMax, ' Минимальное число и его номер ', min, ' ', nMin); end.
begin var ar:=ReadArrInteger(15); writeln('Max:',ar.Max); writeln('Max index:',ar.IndexMax+1); writeln('Min:',ar.Min); writeln('Min index:',ar.IndexMin+1); end.
i, min, max, nMin, nMax:integer;
begin
writeln('Введите 15 элементов массива');
for i := 1 to 15 do
readln(mas[i]);
min := mas[1];
max := mas[1];
nMin := 1;
nMax := 1;
for i := 1 to 15 do
begin
if max < mas[i] then
begin
max := mas[i];
nMax := i;
end;
if min > mas[i] then
begin
min := mas[i];
nMin := i;
end;
end;
writeln('Максимальное число и его номер ', max, ' ', nMax, ' Минимальное число и его номер ', min, ' ', nMin);
end.
begin
var ar:=ReadArrInteger(15);
writeln('Max:',ar.Max);
writeln('Max index:',ar.IndexMax+1);
writeln('Min:',ar.Min);
writeln('Min index:',ar.IndexMin+1);
end.