Написать программу обработки двумерного массива: дан массив а 15 строк и 15 столбцов. заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива нужно в тетраде написать нужно написать так,как в паскале

bobina2 bobina2    1   31.05.2019 14:10    2

Ответы
smashsmash83p08jrb smashsmash83p08jrb  01.07.2020 23:47
var a, b, c, d, i, j :integer;
     s :array [1..100,1..100] of integer;
begin
   b:=63999;
   c:=-63999;
   for i:=1 to 15 do
      begin
      writeln;
      for j:=1 to 15 do
         begin
         s[i,j]:=random(127998)-63999;
         a:=a+s[i,j];
         if s[i,j]>c then c:=s[i,j];
         if s[i,j]<b then b:=s[i,j];
         write (s[i,j],' ');
         end;
      end;
   writeln;
   writeln ('Сумма элементов = ', a);
   writeln ('Максимальный элемент = ', c);
   writeln ('Минимальный элемент = ', b);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика