Написать программу обмена переменных x и y , без использования дополнительных велечин , ( это надо делать в pascal)

даша084 даша084    2   25.06.2019 19:50    0

Ответы
Sonyavishnya Sonyavishnya  20.07.2020 20:28
Var
  a,b:integer;
begin
  a:=50; b:=-20; { начальное присванивание }
  Writeln('Исходные значения: a=',a,', b=',b);
  a:=a+b; b:=a-b; a:=a-b;
  Writeln('Обмен после "арифметического"
  a:=50; b:=-20; { начальное присванивание }
  a:=a xor b; b:=a xor b; a:=a xor b;
  Writeln('Обмен после "логического"
end.

Результат выполнения программы:
Исходные значения: a=50, b=-20
Обмен после "арифметического"
Обмен после "логического"
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика