Написать программу нахождения суммы нечётных цифр в натуральном числе. pascal

emiliahouse emiliahouse    2   19.07.2019 03:20    1

Ответы
ekatsinrom ekatsinrom  03.10.2020 07:34
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
  var n:=ReadInteger('n=');
  var s:=0;
  while n<>0 do begin
    var d:=n mod 10;
    if Odd(d) then s+=d;
    n:=n div 10
    end;
  Writeln('Сумма нечетных равна ',s)
end.

Тестовое решение:
n= 25325423
Сумма нечетных равна 16
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика