Написать программу нахождения количества элементов, меньших 13 и кратных 8 массива а[8] заполненного случайными числами [-50,25)​

bomicbomic bomicbomic    1   06.12.2019 02:18    0

Ответы
skidan2002 skidan2002  10.10.2020 18:59

var a:array [1..10] of integer;

i,j:integer;

begin

 for i:=1 to 10 do a[i]:=random(-50,25);

 writeln ('Массив:');

 writeln (a);

 writeln ('Числа меньше 13 и кратные a[8]:');

 for i:=1 to 10 do

 if (a[i]<13) and (abs(a[i]) mod abs(a[8])=0 ) then write (a[i],' ');

end.

ПОКАЗАТЬ ОТВЕТЫ
мирэлюзий мирэлюзий  10.10.2020 18:59

var i,k:integer;

a:array [1..8] of integer;

begin

write('Массив');

for i:=1 to 8 do

begin

a[i]:=random (75)-50;

write(a[i]:4);

if (a[i]<13) and (a[i] mod 8 = 0 ) then k:=k+1

end;

writeln;

writeln('Количество элементов, меньших 13 и кратных 8 равно ',k);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика