написать программу на языке С#. Дан массив размером nxm, элементы которого целые числа. Подсчитать среднее арифметическое четных элементов, расположенных ниже главной диагонали.

tematal tematal    3   02.11.2020 17:59    3

Ответы
mussa777772 mussa777772  02.12.2020 17:59

на локальных тестах работает

Объяснение:

using System;

class Program

{

   static int P(string p)

   {

       int a = 0, dec = 1;

       for (int i = p.Length - 1; i >= 0; i--)

       {

           a += (p[i] - '0') * dec;

           dec *= 10;

       }

       return a;

   }

   static void Main(string[] args)

   {

       int n = int.Parse(Console.ReadLine());

       int m = int.Parse(Console.ReadLine());

       int c = 0, sum = 0;

       for (int i = 0; i < n; i++)

       {

           int nowSum = 0;

           string a = Console.ReadLine();

           string[] now = a.Split(' ');

           for (int j = 0; j < i; j++)

           {

               int num = P(now[j]);

               if (num % 2 == 0)

               {

                   c++;

                   sum += num;

               }

           }

       }

       Console.WriteLine(sum / c);

       Console.ReadLine();

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика