Написать программу на языке программирования паскаль для вывода массива где каждое последующее число будет прибавляется к заднему, то есть к примеру 9 7 9+7=16 значит у нас будет такой массив 9 7 16 и т.д.

LiliyaEgor LiliyaEgor    3   27.09.2019 02:40    1

Ответы
Mew3200 Mew3200  08.10.2020 21:42
//Первые два числа генерируются случайным образом в диапазоне [-15;15]

const MAX = 250;var
  a: array [1..MAX] of integer;
  i, n: integer;
begin
  randomize;
  write('Размер массива: ');
  readln(n);
  a[1] := random(31) - 15;
  a[2] := random(31) - 15;
  write(a[1]:4, a[2]:4);
  for i := 3 to n do
  begin
    a[i] := a[i - 2] + a[i - 1];
    write(a[i]:5);
  end;
  writeln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Саша7647 Саша7647  08.10.2020 21:42
PascalABC.NET 3.4

// без массива
begin  var (a, b) := ReadInteger2('Задай два первых числа ');
  var n := ReadInteger('Сколько всего чисел надо?');
  Print(a, b);
  for var i := 3 to n do
  begin
    (a, b) := (b, a + b);
    Print(b)
  end
end.

// с массивом
begin
  var n := ReadInteger('Сколько всего чисел надо?');
  var a := new integer[n];
  (a[0], a[1]) := ReadInteger2('Задай два первых числа ');
  for var i := 2 to n - 1 do
    a[i] := a[i - 1] + a[i - 2];
  a.Println
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика