Написать программу на языке паскаля . заданы координаты двух точек. определите, расположены ли они на одной окружности с центром в начале координат. результат присвоить символьной переменной. две точки находятся на одной окружности, если длины радиус-векторов, соединяющих эти точки с началом координат, равны (проверку на равенство осуществить с точностью до е=1.0е-3)

акакий27 акакий27    3   19.03.2019 11:50    5

Ответы
TanyaMakarova26 TanyaMakarova26  26.05.2020 03:17

var x1,x2,y1,y2:real;

a:string;
begin
readln(x1,y1);
readln(x2,y2);
if abs(x1/y1)=abs(x2/y2) then a:='Na odnoi okrujnosti' else a:='Ne na odnoi okrujnosti';

writeln(a);
end.

ПОКАЗАТЬ ОТВЕТЫ
bogdannazarenkomen bogdannazarenkomen  26.05.2020 03:17

var x1,x2,y1,y2:real;

a:string;
begin
readln(x1,y1);
readln(x2,y2);
if abs(x1/y1)=abs(x2/y2) then a:='вот здесь я незнаюi';

writeln(a);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика