Написать программу на языке паскаль, которая подсчитывает количество двоек, троек, четверок и пятерок, полученных за к/р в классе из 20 человек.

филя24 филя24    3   19.09.2019 11:00    2

Ответы
гагарин9 гагарин9  08.10.2020 02:06
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(20,2,5); a.Println;
  var r:=a.GroupBy(t->t).Select(t->(t.Key,t.Count)).OrderBy(t->t[0]);
  foreach var v in r do Writeln(v[0],': ',v[1])
end.
ПОКАЗАТЬ ОТВЕТЫ
oliver6no oliver6no  08.10.2020 02:06
Program ;
var puple_count,mark,two, three, four, five, i: integer;
begin
writeln('Введите количество учеников');
readln(puple_count);
writeln('Введите оценки');
for i:=1 to puple_count do
begin
readln(mark);
case mark of
2 : two := two + 1;
3 : three := three + 1;
4 : four := four + 1;
5 : five := five + 1;
end;
end;
writeln('5: ', five);
writeln('4: ', four);
writeln('3: ', three);
writeln('2: ', two);
end.
Написать программу на языке паскаль, которая подсчитывает количество двоек, троек, четверок и пятеро
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика