Написать программу на языке pascal решения квадратного уравнения. программа должна проверять правильность введенных пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение. нужно

Даша1707 Даша1707    3   19.05.2019 08:40    2

Ответы
Foxy4152 Foxy4152  12.06.2020 12:56

Program yravnenie;

Var
 a,b,c,D,x1,x2,p,q:Real;
Begin
 Repeat
  Write('a= ');
  Readln(a);
  if a=0 then writeln('Error: a=0. Enter another value');
 Until a<>0;
 Write('b= ');
 Readln(b);
 Write('c= ');
 Readln(c);
 p:=b/a;
 q:=c/a;
 D:=Sqr(p/2)-q;
 If D>0 then
  begin
   Writeln('x1 = ',-p/2-Sqrt(D):0:5);
   Writeln('x2 = ',-p/2+Sqrt(D):0:5);
  end
 else
 If D=0 then
  Writeln('x1 = x2 = ',-p/2:0:5)
 else
  begin
   Writeln('x1 = ',-p/2:0:5,'-i*',Sqrt(-D):0:5);
   Writeln('x2 = ',-p/2:0:5,'+i*',Sqrt(-D):0:5);
  end;
 Readln;
End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика