Написать программу на языке PASCAL, реализующую алгоритм решения следующих задач (одной на
выбор):
1. Вывод суммы натуральных чисел в заданном диапазоне
Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы
соответственно
Выходные данные: Число – сумма всех натуральных чисел от N1 до N2 включительно.
2. Вывод произведения натуральных чисел в заданном диапазоне
Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы
соответственно
Выходные данные: Число –произведение всех натуральных чисел от N1 до N2 включительно.

Neymar3110 Neymar3110    3   28.03.2020 14:22    1

Ответы
clever321 clever321  03.09.2020 18:03

Задача 1

var

 i, sum, n1, n2: integer;

begin

 readln(n1, n2);

 for i := n1 to n2 do  

   sum := sum + i;

 writeln(sum);

end.

Задача 2

var

 i, n1, n2: integer;

 p: BigInteger;

begin

 p := 1;

 readln(n1, n2);

 for i := n1 to n2 do  

   p := p * i;

 writeln(p);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика