Написать программу на языке PASCAL, которая в массиве размером 30 со случайными числами ищет нечетные числа и выводит на экран их кол-во.

olga695 olga695    3   13.04.2020 22:13    1

Ответы
Лидия99 Лидия99  13.10.2020 05:02

program answer;

uses CRT;

Var  

a: array [1..30] of integer;

i: integer; n:integer;

begin

clrscr;

for i:=1 to 30 do begin

a[i]:= random(100);

writeln (a[i]);

end;

Writeln ('chetnie chisla s massiva: ');

   for i:=1 to 30 do

       begin

       if ((a[i]) mod 2 = 0) then writeln (a[i])

       end;

end.

ПОКАЗАТЬ ОТВЕТЫ
lazarenko2 lazarenko2  13.10.2020 05:02

// PascalABC.NET

begin

 var a := ArrRandom(30, -99, 99);

 a.Println.Count(p -> p.IsOdd).Print

end.


Написать программу на языке PASCAL, которая в массиве размером 30 со случайными числами ищет нечетны
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика