Написать программу на языке Pascal для нахождения НОД ( наибольшего общего делителя для чисел 4, 8 , 16 , 20 , 24.

olaved1 olaved1    2   20.02.2020 00:48    0

Ответы
DASHAMIronovAAA DASHAMIronovAAA  20.02.2020 01:03

Держи вводи 2 числа и находи нод

Объяснение:

var k, l, n: integer;   function nod (var a,b: integer): integer; var c: integer; begin repeat if a > b then a := a mod b else b := b mod a; until (a = 0) or (b = 0);   nod := a + b; end;   begin   writeln ('Введите два числа: '); readln (k, l);   n := nod (k, l);   writeln ('НОД = ', n);   readln end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика