Написать программу на языке c++ вам даётся 3 числа. требуется установить, возможно ли составить из них пифагоров треугольник. входные данные 3 целых числа, по модулю не превышающие 2 000 000 000. выходные данные если из чисел возможно составить пифагоров треугольник выведите "yes", иначе "no".

Убийца967 Убийца967    1   26.08.2019 12:50    3

Ответы
pzuzuk pzuzuk  05.10.2020 20:58
#include <iostream>
using namespace std;

int main() {
int a, b, c;
cout << "a, b, c: ";
cin >> a >> b >> c;
if ((a*a+b*b==c*c)||(a*a+c*c==b*b)||(b*b+c*c==a*a))
  cout << "YES";
else cout << "NO";
return 0;
}

Пример:
a, b, c: 1960509751 395427000 1999990249
YES
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика