Написать программу на создать файл а4, состоящий из 28 целых чисел. найти среднее арифметическое всех чисел.

Макс11171 Макс11171    3   09.06.2019 03:40    0

Ответы
eva0056 eva0056  01.10.2020 22:48
Program abc;
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
  x, y: longint;
  i: byte;
begin
  y := 0;

  assign(f, 'a4');
  reset(f);

  for i := 1 to 28 do
  begin
    read(f, x);
    y := y + x;
  end;

  writeln(y / 28);
  close(f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика