Написать программу на паскале по : сформировать двумерный массив b размером 4 x 4 (4 – количество строк; 4 – количество столбцов) с генератора случайных чисел и вывести элементы массива на экран и в файл. вычислить и вывести на экран и в файл строку матрицы b, содержащую максимальное количество отрицательных элементов (оформить вычисление количества отрицательных элементов в виде функции).
сделал пока что первую часть, не знаю как дальше:
var ar: array[1..4, 1..4] of integer;
i, j: byte;
f: text;
begin
assign(f,'mas.txt');
rewrite(f);
randomize;
for i: =1 to 4 do
begin
for j: =1 to 4 do
begin
ar[i, j]: = random (200) - 100;
write (inttostr(ar[i, j])+' ');
write (f, inttostr(ar[i, j])+' ');
end;
writeln (f, ''); writeln ();
end;
close (f);
end.

semakina97 semakina97    3   29.10.2019 15:45    4

Ответы
gobon1337 gobon1337  10.10.2020 10:09

program ArrayCalc;

var

 ar: array[1..4, 1..4] of integer;

function Neg (Row: Integer): Integer;

var

 i: Integer;

begin

 Result := 0;

 for i := 1 to 4 do

   if ar [Row, i] <= 0 then

     inc (Result);

end;

var

 i, j, imax, n, nmax: byte;

 f: text;

begin

 assign(f, 'mas.txt');

 rewrite (f);

 randomize;

 for i := 1 to 4 do begin

   for j := 1 to 4 do begin

     ar[i, j] := random (200) - 100;

     write (IntToStr (ar [i, j]) :4);

     write (f, IntToStr (ar [i, j]) :4);

   end;

   writeln (f, '');

   writeln;

 end;

 close (f);

 imax := 1;

 nmax := 0;

 for i := 1 to 4 do begin

   n := Neg (i);

   if n > nmax then begin

     nmax := n;

     imax := i

   end;

 end;

 WriteLn;

 WriteLn ('Строка массива:');

 for j := 1 to 4 do

   Write (ar [imax, j] :4);

 ReadLn;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика