tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале
Написать программу на паскале по функции z=a2-b/a-1 если а=0, то решения нет, потому что на 0 делить нельзя и если a< > 0
Stesha678975425789
3 24.09.2019 17:10
1
Ответы
Саша039
08.10.2020 16:00
Не понял с a2, если не квадрат, то позже исправлю
program func;
var
a, b: integer;
z: real;
begin
writeln('Введите a и b');
readln(a,b);
if a=0 then
writeln('Решения нет')
else if a<>0 then
begin
z:=((Sqr(a)-b)/(a-1));
writeln('z=',z);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
якек2
22.04.2020 20:57
Построит чертеж в виде фронтальная диметрическая проекция картинка 2...
Лиопольд
22.04.2020 20:57
Решите 2 задачи по Информатике с объяснением!...
julss11
22.04.2020 20:57
Определите объем видеопамяти в мегабайтах, необходимой для хранения графического изображения, занимающего весь экран монитора с разрешением 1280 х 1024 и палитрой...
помогите1188
22.04.2020 20:57
1 Свойства алгоритма: a) новизна, понятность, массовость, дискретность, результативность b) дискретность, результативностть, массовость, понятиность c) массовость,...
диманназаров
22.04.2020 20:57
Известно значение трёх чисел. Определить наибольшее Примечание: использовать ReadLn и ячейки Y, a, b, c вид экрана: Ввести с клавиатуры три целых числа в ячейки А,В,С:...
Alexsandar
15.06.2019 22:00
Дoмен верхнего уровня .ru показывает принадлежность интернет ресурса к (российской, румынской, руандийской зоне)?...
GreenBaguette
27.06.2019 21:30
Переведите число 54,677. из десятичной в двоичную...
diana22022005
07.10.2019 21:26
(c++) користувачем задано кількість послідовності n та набір дійсних чисел, що є членами послідовності а. знайти кільквість членів найдовшої полідовності, що складається...
ПоляБондарь
07.10.2019 22:20
№407 исполнитель чертёжник перемещается на координатной плоскости, оставляя след в виде линии. чертёжник может выполнять команду сместиться на (a, b)...
Vita0814
18.08.2019 19:30
Интерфейс представляющий пользователям наиболее удобные взаимодействия с программным обеспечением...
Популярные вопросы
1. представьте в виде степени: а) а3 *а7 ; б) y10* y ; в) ( -а5)*(-а7)...
2
Unit 7 my schoollesson 3 is this 41 look and complete....
2
W=32 литра дельто p=10 атм e=13500кгс/см в кубе найти w1...
3
Ем было вызвано введение опричнины? при иване грознога от руки...
1
Выберите предложение, в котором знаки препинания расставлены верно....
3
2тапсырма составить предложения ! 100...
1
Через 20 минут ! про отношения татьяны и онегина. коротко, кто...
2
расставьте знаки препинания. и выделите вводные слова и определите...
2
Написать эссэ на языке на тему верблюжее молоко...
3
Вправлении какого короля началось укрепление монархической власти...
3
program func;
var
a, b: integer;
z: real;
begin
writeln('Введите a и b');
readln(a,b);
if a=0 then
writeln('Решения нет')
else if a<>0 then
begin
z:=((Sqr(a)-b)/(a-1));
writeln('z=',z);
end;
end.