Написать программу на паскале, которая вводит массив из n целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. протестировать программу для следующих массивов: а) 3 5 -2 0 -6 -8 1 б) -1 -2 -3 0 -1 2 3 массивы должны вводися вручную а не рандомно.

Zhuchkov270302 Zhuchkov270302    1   14.03.2019 18:00    59

Ответы
EzVikaEz EzVikaEz  25.05.2020 08:40

var a: array[1..100] of integer;

n, i: integer;

begin

write('Введите количество элементов массива');

readln(n);

write('Вводите элементы массива отделяя их клавишей "Enter"');

for i:=1 to n do 

read(a[i]);

for i:=1 to n do 

if a[i]<0 then write('число ', a[i], ', номер ', i,'; ' );

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика