Написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше

tanyaaksenova1 tanyaaksenova1    1   16.09.2019 15:50    4

Ответы
двоечник60 двоечник60  07.10.2020 20:01
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger('Введите число').ToString();
var (d1,d4):=(a[1].ToDigit(),a[4].ToDigit());
writeln('первая: ',d1,'; четвертая: ',d4);
if d1>d4 then write ('больше ',d1) else if d1<d4 then write('больше ',d4) else
write('цифры равны: ',d1);
end.
ПОКАЗАТЬ ОТВЕТЫ
KILOBAIT KILOBAIT  07.10.2020 20:01
Var
x:integer;
begin
Read(x);
Writeln(x div 1000, ' ', x mod 10);
if x div 1000 > x mod 10 then Writeln(x div 1000, ' - больше');
if x div 1000 < x mod 10 then Writeln(x mod 10, ' - больше');
if x div 1000 = x mod 10 then Writeln('Они равны');
end.

Пример:
1234
1 4
4 - больше
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика