Написать программу на паскале которая определяет, каков процент пробелов во введенном тексте.

aigamal aigamal    1   08.06.2019 16:20    0

Ответы
Лущік Лущік  07.07.2020 19:05
Var
  s: string;
  i, n, k: integer;

begin
  writeln('Введите текст');
  readln(s);
  n := Length(s);
  k := 0;
  for i := 1 to n do
    if s[i] = ' ' then k := k + 1;
  writeln('Количество пробелов в тексте- ', k)
end.

Тестовый пример:

Введите текст
А роза упала на лапу Азора, а тут ДВА пробела  , а тут вообще пять:     : Все!
Количество пробелов в тексте- 21
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика