Написать программу на паскале: "если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «ошибка ввода»."

димасик138 димасик138    3   20.05.2019 14:00    0

Ответы
xxx158 xxx158  14.06.2020 00:22

program z1;
uses crt;
var n:integer;
begin
writeln(''вв число');
readln(n);
if n>999 then writeln('ошибка ввода') else
if n>100 then writeln((n div 100)*10+n mod 10 ) else
writelnn div 10)*2)*10)+((n mod 10)*2));
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика