tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале
Написать программу на паскале дана строка символов.определить длину самого длинного слова и напечатать его. желательно написать программу с функции pos
rizakovaarina
3 19.07.2019 02:40
0
Ответы
ame5
03.10.2020 07:34
Var
Text, Slovo, max:string;
Begin
WriteLn('Введите строку, разделенную пробелами: '); ReadLn(Tex);
Text:= Text + ' ';
max:='';
While Pos(' ',Text) <> 0 do
Begin
Slovo:= Copy(Text, 1, Pos(' ',Text) - 1);
Delete(Text, 1, Pos(' ',Text));
if Length(Slovo) > Length(max)
then max:= Slovo;
End;
WriteLn('Самое длинное слово: " ',max,' " его длина ',Length(max));
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
хэюяфй
06.09.2020 00:53
Ақан әліппесін жоғалтты хабарында 4 бит ақпарат бар.ақанның қанша оқулығы болған?...
EkimovaVlada
06.09.2020 00:59
Мысалы, Кітап 100беттен тұрады, бір бетінде - 35 жол, ал беттің Мысалы, Кітап 100 беттен тұрады, бір бетіндеәрбір жолында50 символ бар. Кітаптағы ақпарат өлшемін есептейміз:кітаптың...
Машуничка12
28.10.2020 15:20
написать программу для решения заданной функции. В языке С#...
xXDenchykXx1
28.10.2020 15:19
1)Переведите из 8-ой системы счисления в 2-ую и и 16-ую систему счисления число 4517. 2)Перевести по схеме число 98177(10 с/с):10-16-2-8-10 3)Перевести число 253 из 10-ой...
Марина3611
19.11.2020 18:59
Так, нужен алгоритм в Scratch для решения задачи, когда исполнитель рисует уменьшающиеся квадраты со сторонами 100, 80, 60 и 40 шагов из одной точки. Прикрепите фото программы...
lotostp
03.12.2020 17:48
PYTHON Складіть програму з використанням функційіз параметрами для обчислення двох різнихза розміром прямокутних трикутників із відо-мими значеннями їх катетів і обчисліть...
aidana013
03.12.2020 17:48
Конструкционные материалы Установите соответствие междуконструкционным материалом и его типом.МеталлокерамикаКерамикаІ IСтальКомпозиционныйНеметаллическийМеталлический...
regenko1
22.03.2020 22:50
Информатика выбрать поавильный ответ...
Egorkalyadov03
22.03.2020 22:49
Что такое алгоритм а.язык программирования в.опесание конечной последовательности шагов в решении задач приводящих от исходных данных к требуемому результату д решение...
gwetyalina1345
24.12.2020 05:16
График какой функции будет параллелен графику функции у=3х+5? * у= 3х+5у=х+3у= - 3х+5у=3х-2...
Популярные вопросы
. Характеристика Юлька Ващука.Роль батьків у його вихованні. Питання...
3
8. Установити відповідність між прислівником та формою ступеня порівняння...
2
Задание 2. Реши задачу. Площадь участка 160 квадратных метров. Длина...
1
1. Його ім. яв перекладі з японської означає «банан». а) Мацуо Басьо:...
1
Освежают, цветёт, траву, пением-выполнить морф логический разбор....
3
Задание 5 . ОПИШИТЕ ПРЯМО ПО ПЛАНУ , (ПРЯМО ПО ПУНКТАМ . ) кидаю жалобы...
2
Решить неравенство cosx ≥ √3\2 Решите именно так как в примере ничего...
3
Перепишіть речення. Визначте й підкресліть головні та другорядні члени...
1
Тіло падає під кутом 30 до горизонту з негативною швидкість V0=100...
3
Read the questions about some games, toys and fairy tales. Choose the...
2
Text, Slovo, max:string;
Begin
WriteLn('Введите строку, разделенную пробелами: '); ReadLn(Tex);
Text:= Text + ' ';
max:='';
While Pos(' ',Text) <> 0 do
Begin
Slovo:= Copy(Text, 1, Pos(' ',Text) - 1);
Delete(Text, 1, Pos(' ',Text));
if Length(Slovo) > Length(max)
then max:= Slovo;
End;
WriteLn('Самое длинное слово: " ',max,' " его длина ',Length(max));
ReadLn;
End.