Написать программу на паскале. дана последовательность из n целых положительных чисел и числа x и y, которые встречаются в это последовательности. определить, верно ли , что число x встречается в ней чаще , чем y.

Школьник2O18 Школьник2O18    2   19.10.2019 20:32    0

Ответы
JIuchno JIuchno  10.10.2020 08:03

var

 x,y,n,i,a:integer;

 countX, countY:integer;

begin

 write('N: ');

 readln(n);

 write('X, Y: ');

 readln(x,y);

 countX:=0; countY:=0;

 for i:=1 to N do

   begin

     readln(a);

     if a=x then inc(countX);

     if a=y then inc(countY);

   end;

 if countX > countY then  

   writeln('Verno')

     else

       writeln('Error');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика