Написать программу на pascalabc. найдите положительные и отрицательные целые числа в заданном численном значении n и определите сумму абсолютных значений.

sofiavasulyuk sofiavasulyuk    3   29.09.2019 14:01    6

Ответы
marinatabeleva4 marinatabeleva4  09.10.2020 02:56
PascalABC.NET 3.4.2, сборка 1827 от 08.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(ReadInteger('n='), -50, 50);

 a.Println;

 Writeln('Сумма отрицательных чисел равна ', a.Where(t -> t < 0).Sum);

 Writeln('Сумма положительных чисел равна ', a.Where(t -> t > 0).Sum);

 Write('Максимальное по модулю число ');

 var (m1, m2) := (a.Min, a.Max);

 if Abs(m1) > Abs(m2) then m1.Println

 else m2.Println

end.


Написать программу на pascalabc. найдите положительные и отрицательные целые числа в заданном числен
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика