НАПИСАТЬ ПРОГРАММУ НА Pascal Задача 1: Автобусные остановки
Автобусные остановки расположены через каждые K метров от начала улицы, то есть на расстоянии 0, K, 2K, 3K и т.д. метров от начала. Света от начала улицы N метров, после чего устала и захотела сесть на автобус. Определите, сколько метров нужно пройти Свете до ближайшей остановки.

Входные данные
Программа получает на вход два целых числа K и N, записанных в отдельных строках. 1 ≤ K ≤ 2×109, 1 ≤ N ≤ 2×109.

Выходные данные
Программа должна вывести одно целое число — расстояние до ближайшей остановки.

Система оценивания
Решение, правильно работающее только для случаев, когда числа K и N не превосходят 10000, будет оцениваться в

Hwasooyeon Hwasooyeon    1   29.10.2020 18:17    45

Ответы
ДинаСардина ДинаСардина  28.11.2020 18:18

var

k,n,i:integer;

begin

readln(k,n);

i:=n mod k;

if i<=k div 2 then writeln(i)

  else writeln(abs(i-k));

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика