Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число, превышающее введенное. Обязательно в тетради оформить таблицу входных и выходных данных.

andrey100573p018xj andrey100573p018xj    2   22.01.2021 00:13    2

Ответы
УмНяша01 УмНяша01  21.02.2021 00:15

program Chernovik;

var a: integer;

begin

read(a);

if a mod 10 = 0 then a:=a+1;

while a mod 10 <> 0 do a:=a+1;

write(a)

end.

Объяснение:

картинка

Ввод числа

Если введено круглое число (последняя цифра числа равна 0), то увеличиваем его на 1, т.к. выведенное круглое число, должно превышать введённое

Цикл while: пока последняя цифра числа не равна 0, увеличиваем число на 1

Вывод числа


Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число,
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика