Написать программу, которая запрашивает массив размерности n и выводит на экран сам массив, а также наибольший и наименьший элементы массива. протестировать программу на массивах размерностью 5 и 10 элементов.

xenia00000 xenia00000    3   26.06.2019 09:10    3

Ответы
bayan6 bayan6  21.07.2020 08:35
Var a:array [1..100] of integer;
max, min, n, i:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to 10 do
write(a[i],' ');
max:=-maxint;
min:=maxint;
for i:=1 to n do begin
if a[i]>max then max:=a[i];
if a[i]<min then min:=a[i];
end;
writeln('Наибольший элемент: ',max);
writeln('Наименьший элемент: ',min)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика