Написать программу, которая запрашивает имя файла и распечатывает из него только те строки, которые являются палиндромами(python)

ymniupisos ymniupisos    2   02.09.2019 20:50    2

Ответы
nik232451 nik232451  06.10.2020 13:10
Python 2.7
def main('__init__')
    text=read(file)
    for i in strings(text)
        if i is i.palyndrome()
            print(i)
ПОКАЗАТЬ ОТВЕТЫ
makhero111 makhero111  06.10.2020 13:10
# Python 3.6.1

print("Введите имя файла: ",end='')
f = open(input())
for S in f:
   if S[-1] == '\n':
      S = S[:-1]
   L = len(S)
   B = 1
   for i in range(L//2):
      if S[i] != S[L-i-1]: B = 0
   if B == 1:
      print(S)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика