Написать программу, которая выводит все числа не превышающие заданного числа N, которые делятся без остатка на все свои цифры Обязательно ИМЕННО НА PYTHON

ATAT1 ATAT1    3   22.02.2021 17:44    1

Ответы
АхМеД2233 АхМеД2233  22.02.2021 17:50

ОбъяснениеPython 3.4 (нет под рукой 3.3)

n=int(input("Введите N: "))

s=''

for i in range(-n,0):

   s=s+str(-i)+' '

print(s)

Тестовое решение:

Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32

Type "copyright", "credits" or "license()" for more information.

>>> RESTART

>>>

Введите N: 5

5 4 3 2 1:

ПОКАЗАТЬ ОТВЕТЫ
дрин2 дрин2  22.02.2021 17:50

Объяснение:

Написать программу, которая выводит все числа не превышающие заданного числа N, которые делятся без остатка на все свои цифры

Обязательно ИМЕННО НА PYTHON

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика