Написать программу, которая выдает таблицу значений функции Y = 6x2 + arctg(x), угол вводится в градусах. Перевод угла в радианы предусмотреть в программе. Начальное и конечное значение вводит пользователь. Предусмотрите проверку корректности (начало меньше конца)

#include
#include
#include
#include
void main()

{

setlocale(LC_ALL,"rus");

float x,y1,y2,y,A;

printf("Введите начальное значение x:");

scanf ("%f",&y1);

printf("Введите конечное значение x:");

scanf ("%f",&y2);

if (y1>y2&&y == 3)

for (y = y1;y < y2;y++)

{

A=y*3,14/180;

x=6*pow(x,2) + atan(x);

printf("x=%f\n",x);

}

return 0;

}

в чем ошибка? скажите

федот228 федот228    1   31.05.2020 20:25    11

Ответы
Lool199865 Lool199865  14.09.2020 23:01

Объяснение:

#include<math.h>

#include <locale.h>

#include <stdio.h>

int main()

{

setlocale(LC_ALL, "rus");

float x, xn, n, Y,       y, A;

printf("Введите начальное значение x:");

scanf("%f", &x);

printf("Введите конечное значение x:");

scanf("%f", &xn);

 

printf("Введите шаг :");

scanf("%f", &n);

 

 

while (x <= xn)  

{

     A = x * 3, 14 / 180;

  Y = 6 * pow(x, 2) + atan(A);

   

  x += n;

   

  printf("%5.2f -> %5.2f\n", x, Y);

   }

 

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы