Написать программу, которая вводит массив из n вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число z, этим числом. вывести на экран полученный массив и количество замен. протестировать программу на следующих исходных данных: а) z=10 массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15 б) z=-2 массив: 0 -3,1 11 -7,9 -2,1 -1,9 4

RomeTo RomeTo    3   23.08.2019 19:10    4

Ответы
jdkdjdjjidjdjd jdkdjdjjidjdjd  05.10.2020 15:10
//PascalABC.Net 3.2
begin
var a:=readARRreal('Вводите: ', readinteger('n ='));
var z:=readreal('z ='); var count:=0;
for var i:=0 to length(a)-1 do if a[i]>z then begin
a[i]:=z;
count+=1;
end;
writeln ('Кол-во замен: ', count);
a.Print;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика