Написать программу, которая вставляет число k в заданную возрастающую последовательность таким образом, что в результате полученная последовательность также остается полностью возрастающей. (язык программирования - паскаль) - нужно подредактировать //некоторому счётчику i присваиваем значение 1. далее в цикле while проверяем является ли //a[i] меньше k. если да, то проверяем, i< > n, если да, проверяем и a[i] больше k, если да, //то присваиваем некоторой логической переменной значение true и выходим из цикла.//если true, то вставляем k на i-е место (нужно оговорить отдельно, что под этим понимается), //если нет - то выводим сообщение - втавить нельзя. var a: array[1..11] of integer; i, k, t: integer; begin for i : = 1 to 10 do read(a[i]); read(k); for t : = 1 to 11 do if a[t] > k then break; for i : = 11 downto t + 1 do a[i] : = a[i - 1]; a[t] : = k; for i : = 1 to 11 do write(a[i], ' '); end.

Kostya2347 Kostya2347    1   08.06.2019 13:10    0

Ответы
малыш008 малыш008  07.07.2020 17:59
Var
  a: array[1..11] of integer;
  i, k, t: integer;

begin
  for i := 1 to 10 do
    read(a[i]);
  read(k);
  for t := 1 to 11 do
    if a[t] > k then break;
  for i := 11 downto t + 1 do a[i] := a[i - 1]; a[t] := k;
  for i := 1 to 11 do write(a[i], ' ')
end.

Ваша программа полностью работает и делает то, что должна делать. Проверена вставка в середину и на краях.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика