Написать программу, которая считает сумму: 1\3+2\4+3\5+...+n/(n+2). Переменная n вводится с клавиатуры

цццрпппр1 цццрпппр1    3   31.03.2020 16:25    0

Ответы
milenasargsyan0 milenasargsyan0  12.10.2020 10:36

уточняйте на каком языке программирования нужно написать.

Для примера напишу на С++, но алгоритм везде один и тот же.

int n = 0; // Создаём переменную n;

cin >> n; //Вводим n

double sum = 0.0; // Создаём переменную sum которая является дробью.

for(int i = 1; i<n; i++){ //Создаём цикл который будет выполняться n-количество раз.

sum+=(i/(i+2) // Считаем цикл за формулой

}

cout << sum; // Выводим окончательную суму.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика