Написать программу, которая проверяет, является ли введенная с клавиатуры строка целым числом

klymukmaks klymukmaks    2   01.06.2019 05:50    0

Ответы
смерть75 смерть75  02.07.2020 13:19
VAR
   s: String;
   i: LongInt;
BEGIN
   Read(s);

   for i := 1 to Length(s) do 
      if not((Ord(s[i]) > 47)and(Ord(s[i]) < 58)) then begin
      Write(s,' - не является целым число'); Exit; 
   end;

   Write(s,' - целое число'); 
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика