Написать программу, которая проверяет является ли строка, введенная с клавиатуры палиндромом (пробелы игнорировать). pascal abc

Ivanov11kk22 Ivanov11kk22    1   26.09.2019 22:20    1

Ответы
NastyaSukorkina NastyaSukorkina  27.08.2020 07:50
Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите строку: ');
  Readln(s);
  n:=Length(s);
  for i:=n downto 1 do
    if s[i]=' ' then Delete(s,i,1);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы